Degraded Network Performance in Chicago

Incident Report for Tempest

Resolved

This has been resolved.
Posted Sep 16, 2023 - 14:21 UTC

Investigating

We are investigating reports of degraded network performance in Chicago.
Posted Sep 16, 2023 - 02:53 UTC
This incident affected: North America (Chicago, United States).