Connectivity Issues - London

Incident Report for London , UK

Resolved
Network has been restored.
Posted 24 days ago.
Datacenter
UTCAug 17, 2026, 18:08 UTC
Your time
Monitoring
Cable has been replaced and network looks to have been restored.
Posted 24 days ago.
Datacenter
UTCAug 17, 2026, 17:56 UTC
Your time
Identified
When activating additional load balancers, our a cable within the cabinet has been damaged. We're replacing the damaged cable now.
Posted 24 days ago.
Datacenter
UTCAug 17, 2026, 17:39 UTC
Your time
Investigating
We're currently investigating issues with connectivity in our London location
Posted 24 days ago.
Datacenter
UTCAug 17, 2026, 17:15 UTC
Your time
This incident affected: London , UK.