This incident is now resolved.
If you are still having issues connecting, please open a ticket on the portal.
Posted 15 days ago.
Datacenter—
UTCJun 30, 2026, 13:09 UTC
Your time—
Monitoring
We have been able to bring connectivity back to Amsterdam; all services should be reachable at this point and we are continuing to monitor connectivity.
If you are still having issues connecting, please open a ticket on the portal.
Posted 16 days ago.
Datacenter—
UTCJun 29, 2026, 19:08 UTC
Your time—
Identified
We have identified this problem as a core switch failure.
Amsterdam is a site where we haven't had the chance to ship a spare yet, so we are engaging with local vendors to source a replacement.
Updates will be posted as we have them.
Posted 19 days ago.
Datacenter—
UTCJun 26, 2026, 12:02 UTC
Your time—
Investigating
We are investigating an outage with our Amsterdam location.